You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
When we configure RIP protocol with the following configuration
int r1-eth0
ip address XXXX
router rip
network r1-eth0
passive-interface default
passive-interface r1-eth0
no passive-interface default
The running-config is as following, which is wrong
int r1-eth0
ip address XXXX
router rip
network r1-eth0
The no passive-interface default will also cancling passive-interface r1-eth0, leaving all interfaces active, which is an unexpected behavior as the r1-eth0 is explicitly marked as passive. If we want to set r1-eth0 active, we should use an explicit command no passive-interface r1-eth0.
The right running-config should be
int r1-eth0...
ip address XXX
router rip
passive-interface r1-eth0
This behavior should be same as those in other protocols such as OSPF. For example,
int r1-eth0
ip address XXX
ip ospf passive
ip ospf area 1
router ospf
passive interface default
no passive interface default
The running-configuration is
int r1-eth0
ip address XXX
ip ospf passive
router ospf
Here the no passive interface default command only cancles passive interface default command, leaving ip ospf passive alive
Version
10.3
How to reproduce
Input
router rip
passive-interface default
passive-interface r1-eth0
no passive-interface default
Expected behavior
show running-config
router rip
passive-interface r1-eth0
Actual behavior
show running-config
router rip
Additional context
No response
Checklist
I have searched the open issues for this bug.
I have not included sensitive information in this report.
The text was updated successfully, but these errors were encountered:
Description
When we configure RIP protocol with the following configuration
The running-config is as following, which is wrong
The
no passive-interface default
will also canclingpassive-interface r1-eth0
, leaving all interfaces active, which is an unexpected behavior as ther1-eth0
is explicitly marked as passive. If we want to setr1-eth0
active, we should use an explicit commandno passive-interface r1-eth0
.The right running-config should be
This behavior should be same as those in other protocols such as
OSPF
. For example,The running-configuration is
Here the
no passive interface default
command only canclespassive interface default
command, leavingip ospf passive
aliveVersion
How to reproduce
Input
Expected behavior
show running-config
Actual behavior
show running-config
Additional context
No response
Checklist
The text was updated successfully, but these errors were encountered: