Skip to content

Commit 5b220b9

Browse files
committed
toolchain/uclibc: propagate mips mips32r2 variant setting to uclibc
0.9.30 supports MIPS_ISA_MIPS32R2, so use it if mips32r2 variant is selected.
1 parent 215e91f commit 5b220b9

File tree

1 file changed

+3
-2
lines changed

1 file changed

+3
-2
lines changed

toolchain/uClibc/uclibc.mk

+3-2
Original file line numberDiff line numberDiff line change
@@ -185,6 +185,7 @@ ifeq ($(UCLIBC_TARGET_ARCH),mips)
185185
/bin/echo "# CONFIG_MIPS_ISA_3 is not set"; \
186186
/bin/echo "# CONFIG_MIPS_ISA_4 is not set"; \
187187
/bin/echo "# CONFIG_MIPS_ISA_MIPS32 is not set"; \
188+
/bin/echo "# CONFIG_MIPS_ISA_MIPS32R2 is not set"; \
188189
/bin/echo "# CONFIG_MIPS_ISA_MIPS64 is not set"; \
189190
) >> $(UCLIBC_DIR)/.oldconfig
190191
ifeq ($(BR2_MIPS_OABI),y)
@@ -209,10 +210,10 @@ ifeq ($(BR2_mips_4),y)
209210
$(SED) 's/.*\(CONFIG_MIPS_ISA_4\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
210211
endif
211212
ifeq ($(BR2_mips_32),y)
212-
$(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
213+
$(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\)[^R].*/\1=y/' $(UCLIBC_DIR)/.oldconfig
213214
endif
214215
ifeq ($(BR2_mips_32r2),y)
215-
$(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
216+
$(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32R2\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
216217
endif
217218
ifeq ($(BR2_mips_64),y)
218219
$(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS64\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig

0 commit comments

Comments
 (0)