Skip to content

Commit f3fbf3a

Browse files
committed
firmware/skiboot: Enable embedded kernel payloads in skiboot image
Skiboot LID files can contain a kernel payload by specifying KERNEL= during skiboot build. Signed-off-by: Jeremy Kerr <[email protected]>
1 parent 584193c commit f3fbf3a

File tree

2 files changed

+21
-1
lines changed

2 files changed

+21
-1
lines changed

firmware/skiboot/Config.in

+8
Original file line numberDiff line numberDiff line change
@@ -4,3 +4,11 @@ config BR2_TARGET_SKIBOOT
44
depends on BR2_powerpc64
55
help
66
Build skiboot POWER8 firmware
7+
8+
if BR2_TARGET_SKIBOOT
9+
10+
config BR2_TARGET_SKIBOOT_EMBED_PAYLOAD
11+
bool "Embed kernel payload in skiboot image"
12+
depends on BR2_LINUX_KERNEL_ZIMAGE_EPAPR
13+
14+
endif

firmware/skiboot/skiboot.mk

+13-1
Original file line numberDiff line numberDiff line change
@@ -7,9 +7,21 @@
77
SKIBOOT_VERSION = 1d880992fd8c8457a2d990ac6622cfd58fb1b261
88
SKIBOOT_SITE = $(call github,open-power,skiboot,$(SKIBOOT_VERSION))
99
SKIBOOT_INSTALL_IMAGES = YES
10+
SKIBOOT_INSTALL_TARGET = NO
11+
12+
ifeq ($(BR2_TARGET_SKIBOOT_EMBED_PAYLOAD),y)
13+
SKIBOOT_MAKE_OPTS += KERNEL="$(BINARIES_DIR)/$(LINUX_IMAGE_NAME)"
14+
15+
ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
16+
SKIBOOT_DEPENDENCIES += linux26-rebuild-with-initramfs
17+
else
18+
SKIBOOT_DEPENDENCIES += linux
19+
endif
20+
21+
endif
1022

1123
define SKIBOOT_BUILD_CMDS
12-
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) all
24+
$(TARGET_CONFIGURE_OPTS) $(MAKE) $(SKIBOOT_MAKE_OPTS) -C $(@D) all
1325
endef
1426

1527
define SKIBOOT_INSTALL_IMAGES_CMDS

0 commit comments

Comments
 (0)