Skip to content

Commit 4269c72

Browse files
zloeberosterman
authored andcommitted
[rancher] Add Package (#288)
1 parent 15a0694 commit 4269c72

File tree

8 files changed

+34
-0
lines changed

8 files changed

+34
-0
lines changed

.github/auto-label.yml

+1
Original file line numberDiff line numberDiff line change
@@ -67,6 +67,7 @@ vendor/misspell: vendor/misspell/**
6767
vendor/packer: vendor/packer/**
6868
vendor/pandoc: vendor/pandoc/**
6969
vendor/rakkess: vendor/rakkess/**
70+
vendor/rancher: vendor/rancher/**
7071
vendor/rbac-lookup: vendor/rbac-lookup/**
7172
vendor/retry: vendor/retry/**
7273
vendor/scenery: vendor/scenery/**

README.md

+1
Original file line numberDiff line numberDiff line change
@@ -287,6 +287,7 @@ misspell 0.3.4 Correct commonly misspelled English words i
287287
packer 1.4.4 Packer is a tool for creating identical machine images for multiple platforms from a single source configuration.
288288
pandoc 2.8 Universal markup converter
289289
rakkess 0.4.2 Review Access - kubectl plugin to show an access matrix for all available resources
290+
rancher 2.3.2 Rancher CLI
290291
rbac-lookup 0.5.0 Find Kubernetes roles and cluster roles bound to any user, service account, or group name.
291292
retry 3.3.0 ♻️ Functional mechanism based on channels to perform actions repetitively until successful.
292293
scenery 0.1.5 A Terraform plan output prettifier

docs/targets.md

+1
Original file line numberDiff line numberDiff line change
@@ -51,6 +51,7 @@ misspell 0.3.4 Correct commonly misspelled English words i
5151
packer 1.4.4 Packer is a tool for creating identical machine images for multiple platforms from a single source configuration.
5252
pandoc 2.8 Universal markup converter
5353
rakkess 0.4.2 Review Access - kubectl plugin to show an access matrix for all available resources
54+
rancher 2.3.2 Rancher CLI
5455
rbac-lookup 0.5.0 Find Kubernetes roles and cluster roles bound to any user, service account, or group name.
5556
retry 3.3.0 ♻️ Functional mechanism based on channels to perform actions repetitively until successful.
5657
scenery 0.1.5 A Terraform plan output prettifier

vendor/rancher/DESCRIPTION

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
Rancher CLI

vendor/rancher/LICENSE

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
MIT

vendor/rancher/Makefile

+27
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,27 @@
1+
## Typical Github binary release
2+
3+
## Package details
4+
export VENDOR = rancher
5+
export PACKAGE_NAME = rancher
6+
# Folder which package is extracted into
7+
export PACKAGE_REPO_NAME = cli
8+
export DOWNLOAD_URL ?= $(PACKAGE_REPO_URL)/releases/download/v$(PACKAGE_VERSION)/rancher-$(OS)-$(ARCH)-v$(PACKAGE_VERSION).tar.gz
9+
10+
## APK build specific requirements
11+
export APK_BUILD_TEMPLATE ?= APKBUILD.github-binary
12+
## Uncomment only if you need additional libraries
13+
#export APKBUILD_DEPENDS += libc6-compat musl
14+
15+
include ../../tasks/Makefile.package
16+
include ../../tasks/Makefile.apk
17+
18+
install:
19+
$(call download_tarball)
20+
21+
test:
22+
$(PACKAGE_EXE) --version
23+
24+
## This may be required for apk building and varies from package to package
25+
## Custom post-package processing (Note the double colon to append to current inherited package/prepare task)
26+
package/prepare::
27+
mv src/rancher-v$(PACKAGE_VERSION)/rancher src

vendor/rancher/RELEASE

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
0

vendor/rancher/VERSION

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
2.3.2

0 commit comments

Comments
 (0)