Skip to content

Commit 4f1f841

Browse files
cloudpossebotNuru
andauthored
Update atlantis to 0.17.0 (#1192)
* Update atlantis to 0.16.1 → 0.17.0 * Add Alpine libc6-compat dependency Co-authored-by: cloudpossebot <[email protected]> Co-authored-by: Nuru <[email protected]>
1 parent c87e595 commit 4f1f841

File tree

5 files changed

+9
-5
lines changed

5 files changed

+9
-5
lines changed

README.md

+1-1
Original file line numberDiff line numberDiff line change
@@ -291,7 +291,7 @@ Here are some solutions to several common problems that may occur when adding a
291291
[![amtool](https://github.com/cloudposse/packages/workflows/amtool/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aamtool) | 0.21.0 | Tool for interacting with the Alertmanager API
292292
[![argocd](https://github.com/cloudposse/packages/workflows/argocd/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aargocd) | 2.0.1 | Declarative GitOpts for Kubernetes
293293
[![assume-role](https://github.com/cloudposse/packages/workflows/assume-role/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aassume-role) | 0.3.2 | Easily assume AWS roles in your terminal.
294-
[![atlantis](https://github.com/cloudposse/packages/workflows/atlantis/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aatlantis) | 0.16.1 | Terraform For Teams
294+
[![atlantis](https://github.com/cloudposse/packages/workflows/atlantis/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aatlantis) | 0.17.0 | Terraform For Teams
295295
[![atmos](https://github.com/cloudposse/packages/workflows/atmos/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aatmos) | 0.17.2 | Universal Tool for DevOps and Cloud Automation
296296
[![awless](https://github.com/cloudposse/packages/workflows/awless/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aawless) | 0.1.11 | A Mighty CLI for AWS
297297
[![aws-iam-authenticator](https://github.com/cloudposse/packages/workflows/aws-iam-authenticator/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aaws-iam-authenticator) | 0.5.3 | A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster

docs/badges.md

+1-1
Original file line numberDiff line numberDiff line change
@@ -4,7 +4,7 @@
44
[![amtool](https://github.com/cloudposse/packages/workflows/amtool/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aamtool) | 0.21.0 | Tool for interacting with the Alertmanager API
55
[![argocd](https://github.com/cloudposse/packages/workflows/argocd/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aargocd) | 2.0.1 | Declarative GitOpts for Kubernetes
66
[![assume-role](https://github.com/cloudposse/packages/workflows/assume-role/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aassume-role) | 0.3.2 | Easily assume AWS roles in your terminal.
7-
[![atlantis](https://github.com/cloudposse/packages/workflows/atlantis/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aatlantis) | 0.16.1 | Terraform For Teams
7+
[![atlantis](https://github.com/cloudposse/packages/workflows/atlantis/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aatlantis) | 0.17.0 | Terraform For Teams
88
[![atmos](https://github.com/cloudposse/packages/workflows/atmos/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aatmos) | 0.17.2 | Universal Tool for DevOps and Cloud Automation
99
[![awless](https://github.com/cloudposse/packages/workflows/awless/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aawless) | 0.1.11 | A Mighty CLI for AWS
1010
[![aws-iam-authenticator](https://github.com/cloudposse/packages/workflows/aws-iam-authenticator/badge.svg?branch=master)](https://github.com/cloudposse/packages/actions?query=workflow%3Aaws-iam-authenticator) | 0.5.3 | A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster

docs/targets.md

+1-1
Original file line numberDiff line numberDiff line change
@@ -4,7 +4,7 @@
44
amtool 0.21.0 Tool for interacting with the Alertmanager API
55
argocd 2.0.1 Declarative GitOpts for Kubernetes
66
assume-role 0.3.2 Easily assume AWS roles in your terminal.
7-
atlantis 0.16.1 Terraform For Teams
7+
atlantis 0.17.0 Terraform For Teams
88
atmos 0.17.2 Universal Tool for DevOps and Cloud Automation
99
awless 0.1.11 A Mighty CLI for AWS
1010
aws-iam-authenticator 0.5.3 A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster

vendor/atlantis/Makefile

+5-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22
export VENDOR ?= runatlantis
33
export DOWNLOAD_URL ?= $(PACKAGE_REPO_URL)/releases/download/v$(PACKAGE_VERSION)/$(PACKAGE_NAME)_$(OS)_$(ARCH).zip
44
export APK_BUILD_TEMPLATE ?= APKBUILD.github-binary
5-
export APKBUILD_DEPENDS += dpkg
5+
export APKBUILD_DEPENDS += dpkg libc6-compat
66
export APKBUILD_INSTALL_SCRIPTS = $(PACKAGE_NAME).post-install $(PACKAGE_NAME).post-deinstall
77
export MASTER_PACKAGE_NAME = atlantis
88
export INSTALL_DIR = /usr/share/${MASTER_PACKAGE_NAME}/${VENDOR}/bin
@@ -13,5 +13,9 @@ install:
1313
$(call download_zip)
1414

1515
test:
16+
@echo testing atlantis
17+
atlantis
18+
@echo checking atlantis version against $(PACKAGE_VERSION)
19+
$(PACKAGE_EXE) version
1620
$(PACKAGE_EXE) version | grep -F $(PACKAGE_VERSION)
1721

vendor/atlantis/VERSION

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
0.16.1
1+
0.17.0

0 commit comments

Comments
 (0)