Skip to content

Commit e82b638

Browse files
authored
addpkg: chmlib (#195)
1 parent 23e91a3 commit e82b638

File tree

2 files changed

+39
-0
lines changed

2 files changed

+39
-0
lines changed

Diff for: chmlib/define-riscv64-sized-types.patch

+16
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,16 @@
1+
diff --color -Naur chmlib-0.40-orig/src/chm_lib.c chmlib-0.40/src/chm_lib.c
2+
--- chmlib-0.40-orig/src/chm_lib.c 2009-05-23 22:43:31.000000000 +0800
3+
+++ chmlib-0.40/src/chm_lib.c 2021-10-05 22:37:55.450952995 +0800
4+
@@ -162,9 +162,10 @@
5+
typedef long long Int64;
6+
typedef unsigned long long UInt64;
7+
8+
-/* x86-64 */
9+
+/* x86-64 */
10+
+/* riscv64 */
11+
/* Note that these may be appropriate for other 64-bit machines. */
12+
-#elif __x86_64__ || __ia64__
13+
+#elif __x86_64__ || __ia64__ || (__riscv && (__riscv_xlen == 64))
14+
typedef unsigned char UChar;
15+
typedef short Int16;
16+
typedef unsigned short UInt16;

Diff for: chmlib/riscv64.patch

+23
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,23 @@
1+
diff --git PKGBUILD PKGBUILD
2+
index 0b418e4..4cba9ef 100644
3+
--- PKGBUILD
4+
+++ PKGBUILD
5+
@@ -10,12 +10,16 @@ arch=('x86_64')
6+
url="http://www.jedrea.com/chmlib/"
7+
license=('LGPL')
8+
depends=('glibc')
9+
-source=("http://www.jedrea.com/chmlib/chmlib-0.40.tar.bz2")
10+
-md5sums=('7ea49ed8c335215c1edc6fae83e6b912')
11+
+source=("http://www.jedrea.com/chmlib/chmlib-0.40.tar.bz2"
12+
+ "define-riscv64-sized-types.patch")
13+
+md5sums=('7ea49ed8c335215c1edc6fae83e6b912'
14+
+ 'd3ff2aa4ad18180b9955020b05396e6f')
15+
16+
build() {
17+
cd "${srcdir}"/${pkgname}-${pkgver}
18+
19+
+ patch -Np1 -i ../define-riscv64-sized-types.patch
20+
+
21+
./configure --prefix=/usr \
22+
--enable-examples=yes
23+
make

0 commit comments

Comments
 (0)