Skip to content

Commit 1a1ecfc

Browse files
committed
Merge branch '4.8.0' into merge-4.8.0-into-4.8.1
2 parents c27ace0 + 67c70c8 commit 1a1ecfc

File tree

31 files changed

+455
-304
lines changed

31 files changed

+455
-304
lines changed

.github/workflows/build-deb-packages.yml

+1-1
Original file line numberDiff line numberDiff line change
@@ -68,7 +68,7 @@ jobs:
6868
if: steps.changes.outputs.deb_packages == 'true' || (steps.changes.outputs.deb_images_agent_i386 == 'true' && matrix.ARCHITECTURE == 'i386') || ((steps.changes.outputs.deb_images_manager_amd64 == 'true' || steps.changes.outputs.deb_images_agent_amd64 == 'true') && matrix.ARCHITECTURE == 'amd64')
6969
working-directory: ./debs
7070
run: |
71-
REVISION="${{ github.head_ref }}"
71+
REVISION=$( echo ${{ github.head_ref }} | sed 's/-/./g; s/\//./g' )
7272
bash generate_debian_package.sh -b ${{ env.VERSION }} -t ${{ matrix.TYPE }} -a ${{ matrix.ARCHITECTURE }} --dev -j 2 --dont-build-docker --tag ${{ env.TAG }} -r $REVISION
7373
echo "PACKAGE_NAME=$(ls ./output | grep .deb | head -n 1)" >> $GITHUB_ENV
7474

.github/workflows/build-rpm-packages.yml

+1-1
Original file line numberDiff line numberDiff line change
@@ -68,7 +68,7 @@ jobs:
6868
if : steps.changes.outputs.rpm_packages == 'true' || (steps.changes.outputs.rpm_images_agent_i386 == 'true' && matrix.ARCHITECTURE == 'i386') || ((steps.changes.outputs.rpm_images_manager_x86_64 == 'true' || steps.changes.outputs.rpm_images_agent_x86_64 == 'true') && matrix.ARCHITECTURE == 'x86_64')
6969
working-directory: ./rpms
7070
run: |
71-
REVISION=$( echo ${{ github.head_ref }} | sed 's/-/./g' )
71+
REVISION=$( echo ${{ github.head_ref }} | sed 's/-/./g; s/\//./g' )
7272
bash generate_rpm_package.sh -b ${{ env.VERSION }} -t ${{ matrix.TYPE }} -a ${{ matrix.ARCHITECTURE }} --dev -j 2 --dont-build-docker --tag ${{ env.TAG }} -r $REVISION
7373
echo "PACKAGE_NAME=$(ls ./output | grep .rpm | head -n 1)" >> $GITHUB_ENV
7474

.github/workflows/test-install-deb.yml

+2-2
Original file line numberDiff line numberDiff line change
@@ -20,7 +20,7 @@ jobs:
2020
skip_after_successful_duplicate: 'false'
2121

2222
- name: Wait for the package to be built
23-
uses: ArcticLampyrid/[email protected].3
23+
uses: ArcticLampyrid/[email protected].4
2424
id: wait-for-build
2525
with:
2626
github_token: ${{ secrets.GITHUB_TOKEN }}
@@ -68,7 +68,7 @@ jobs:
6868
if: steps.changes.outputs.deb_packages == 'true' || (steps.changes.outputs.deb_images_agent_i386 == 'true' && matrix.ARCHITECTURE == 'i386') || (steps.changes.outputs.deb_images_amd64 == 'true' && matrix.ARCHITECTURE == 'amd64')
6969
run: |
7070
VERSION=$(cat $GITHUB_WORKSPACE/VERSION)
71-
REVISION=$( echo ${{ github.head_ref }})
71+
REVISION=$( echo ${{ github.head_ref }} | sed 's/-/./g; s/\//./g' )
7272
echo "PACKAGE_NAME=wazuh-${{ matrix.type }}_${VERSION}-${REVISION}_${{ matrix.arch }}.deb" >> $GITHUB_ENV
7373
7474
- name: Download the Wazuh ${{ matrix.type }} package for ${{ matrix.system.NAME }}

.github/workflows/test-install-rpm.yml

+2-2
Original file line numberDiff line numberDiff line change
@@ -19,7 +19,7 @@ jobs:
1919
skip_after_successful_duplicate: 'false'
2020

2121
- name: Wait for the package to be built
22-
uses: ArcticLampyrid/[email protected].3
22+
uses: ArcticLampyrid/[email protected].4
2323
id: wait-for-build
2424
with:
2525
github_token: ${{ secrets.GITHUB_TOKEN }}
@@ -77,7 +77,7 @@ jobs:
7777
if : steps.changes.outputs.rpm_packages == 'true' || (steps.changes.outputs.rpm_images_agent_i386 == 'true' && matrix.ARCHITECTURE == 'i386') || (steps.changes.outputs.rpm_images_x86_64 == 'true' && matrix.ARCHITECTURE == 'x86_64')
7878
run: |
7979
VERSION=$(cat $GITHUB_WORKSPACE/VERSION)
80-
REVISION=$( echo ${{ github.head_ref }} | sed 's/-/./g' )
80+
REVISION=$( echo ${{ github.head_ref }} | sed 's/-/./g; s/\//./g' )
8181
echo "PACKAGE_NAME=wazuh-${{ matrix.type }}-${VERSION}-${REVISION}.${{matrix.system.ARCH}}.rpm" >> $GITHUB_ENV
8282
8383
- name: Download the Wazuh ${{ matrix.type }} package for ${{ matrix.system.NAME }}

aix/SPECS/wazuh-agent-aix.spec

+2-2
Original file line numberDiff line numberDiff line change
@@ -294,11 +294,11 @@ rm -fr %{buildroot}
294294
- More info: https://documentation.wazuh.com/current/release-notes/release-4-8-1.html
295295
* Fri Dec 15 2023 support <[email protected]> - 4.8.0
296296
- More info: https://documentation.wazuh.com/current/release-notes/release-4-8-0.html
297-
* Thu Dec 07 2023 support <[email protected]> - 4.7.1
297+
* Tue Dec 05 2023 support <[email protected]> - 4.7.1
298298
- More info: https://documentation.wazuh.com/current/release-notes/release-4-7-1.html
299299
* Tue Nov 21 2023 support <[email protected]> - 4.7.0
300300
- More info: https://documentation.wazuh.com/current/release-notes/release-4-7-0.html
301-
* Tue Oct 24 2023 support <[email protected]> - 4.6.0
301+
* Tue Oct 31 2023 support <[email protected]> - 4.6.0
302302
- More info: https://documentation.wazuh.com/current/release-notes/release-4-6-0.html
303303
* Tue Oct 24 2023 support <[email protected]> - 4.5.4
304304
- More info: https://documentation.wazuh.com/current/release-notes/release-4-5-4.html

debs/SPECS/wazuh-agent/debian/changelog

+2-2
Original file line numberDiff line numberDiff line change
@@ -13,13 +13,13 @@ wazuh-agent (4.7.1-RELEASE) stable; urgency=low
1313

1414
* More info: https://documentation.wazuh.com/current/release-notes/release-4-7-1.html
1515

16-
-- Wazuh, Inc <[email protected]> Thu, 07 Dec 2023 00:00:00 +0000
16+
-- Wazuh, Inc <[email protected]> Tue, 05 Dec 2023 00:00:00 +0000
1717

1818
wazuh-agent (4.7.0-RELEASE) stable; urgency=low
1919

2020
* More info: https://documentation.wazuh.com/current/release-notes/release-4-7-0.html
2121

22-
-- Wazuh, Inc <[email protected]> Tue, 21 Nov 2023 00:00:00 +0000
22+
-- Wazuh, Inc <[email protected]> Tue, 05 Nov 2023 00:00:00 +0000
2323

2424
wazuh-agent (4.6.0-RELEASE) stable; urgency=low
2525

debs/SPECS/wazuh-manager/debian/changelog

+2-2
Original file line numberDiff line numberDiff line change
@@ -13,13 +13,13 @@ wazuh-manager (4.7.1-RELEASE) stable; urgency=low
1313

1414
* More info: https://documentation.wazuh.com/current/release-notes/release-4-7-1.html
1515

16-
-- Wazuh, Inc <[email protected]> Thu, 07 Dec 2023 00:00:00 +0000
16+
-- Wazuh, Inc <[email protected]> Tue, 05 Dec 2023 00:00:00 +0000
1717

1818
wazuh-manager (4.7.0-RELEASE) stable; urgency=low
1919

2020
* More info: https://documentation.wazuh.com/current/release-notes/release-4-7-0.html
2121

22-
-- Wazuh, Inc <[email protected]> Tue, 21 Nov 2023 00:00:00 +0000
22+
-- Wazuh, Inc <[email protected]> Tue, 05 Nov 2023 00:00:00 +0000
2323

2424
wazuh-manager (4.6.0-RELEASE) stable; urgency=low
2525

debs/SPECS/wazuh-manager/debian/postinst

+2
Original file line numberDiff line numberDiff line change
@@ -170,6 +170,8 @@ case "$1" in
170170
chmod 0660 ${DIR}/logs/active-responses.log
171171
chmod 0640 ${DIR}/logs/integrations.log
172172

173+
# Set merged.mg permissions to new ones
174+
find ${DIR}/etc/shared/ -type f -name 'merged.mg' -exec chmod 644 {} \;
173175

174176
if [ -f ${DIR}/etc/shared/ar.conf ]; then
175177
chown root:wazuh ${DIR}/etc/shared/ar.conf

debs/SPECS/wazuh-manager/debian/rules

+2
Original file line numberDiff line numberDiff line change
@@ -130,6 +130,7 @@ override_dh_install:
130130
mkdir -p ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/20
131131
mkdir -p ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/21
132132
mkdir -p ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/22
133+
mkdir -p ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/23
133134
mkdir -p ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/debian/7
134135
mkdir -p ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/debian/8
135136
mkdir -p ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/debian/9
@@ -173,6 +174,7 @@ override_dh_install:
173174
cp etc/templates/config/darwin/20/sca.files ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/20
174175
cp etc/templates/config/darwin/21/sca.files ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/21
175176
cp etc/templates/config/darwin/22/sca.files ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/22
177+
cp etc/templates/config/darwin/23/sca.files ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/darwin/23
176178

177179
cp etc/templates/config/debian/sca.files ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/debian
178180
cp etc/templates/config/debian/7/sca.files ${TARGET_DIR}$(INSTALLATION_SCRIPTS_DIR)/sca/debian/7

macos/package_files/build.sh

+5-4
Original file line numberDiff line numberDiff line change
@@ -35,10 +35,10 @@ function build() {
3535
configure
3636

3737
if [ -z "${USER_BINARYINSTALL}" ]; then
38-
make -C ${SOURCES_PATH}/src deps TARGET=agent
38+
make -C ${SOURCES_PATH}/src deps TARGET=agent
3939

40-
echo "Generating Wazuh executables"
41-
make -j$JOBS -C ${SOURCES_PATH}/src DYLD_FORCE_FLAT_NAMESPACE=1 TARGET=agent build
40+
echo "Generating Wazuh executables"
41+
make -j$JOBS -C ${SOURCES_PATH}/src DYLD_FORCE_FLAT_NAMESPACE=1 TARGET=agent build
4242
fi
4343

4444
echo "Running install script"
@@ -60,7 +60,7 @@ function build() {
6060
find ${SOURCES_PATH}/src/init/ -name *.sh -type f -exec install -m 0640 {} ${INSTALLATION_SCRIPTS_DIR}/src/init \;
6161

6262
mkdir -p ${INSTALLATION_SCRIPTS_DIR}/sca/generic
63-
mkdir -p ${INSTALLATION_SCRIPTS_DIR}/sca/darwin/{15,16,17,18,20,21,22}
63+
mkdir -p ${INSTALLATION_SCRIPTS_DIR}/sca/darwin/{15,16,17,18,20,21,22,23}
6464

6565
cp -r ${SOURCES_PATH}/ruleset/sca/darwin ${INSTALLATION_SCRIPTS_DIR}/sca
6666
cp -r ${SOURCES_PATH}/ruleset/sca/generic ${INSTALLATION_SCRIPTS_DIR}/sca
@@ -73,6 +73,7 @@ function build() {
7373
cp ${SOURCES_PATH}/etc/templates/config/darwin/20/sca.files ${INSTALLATION_SCRIPTS_DIR}/sca/darwin/20/
7474
cp ${SOURCES_PATH}/etc/templates/config/darwin/21/sca.files ${INSTALLATION_SCRIPTS_DIR}/sca/darwin/21/
7575
cp ${SOURCES_PATH}/etc/templates/config/darwin/22/sca.files ${INSTALLATION_SCRIPTS_DIR}/sca/darwin/22/
76+
cp ${SOURCES_PATH}/etc/templates/config/darwin/23/sca.files ${INSTALLATION_SCRIPTS_DIR}/sca/darwin/23/
7677

7778
cp ${SOURCES_PATH}/src/VERSION ${INSTALLATION_SCRIPTS_DIR}/src/
7879
cp ${SOURCES_PATH}/src/REVISION ${INSTALLATION_SCRIPTS_DIR}/src/

rpms/SPECS/wazuh-agent.spec

+2-2
Original file line numberDiff line numberDiff line change
@@ -629,11 +629,11 @@ rm -fr %{buildroot}
629629
- More info: https://documentation.wazuh.com/current/release-notes/release-4-8-1.html
630630
* Fri Dec 15 2023 support <[email protected]> - 4.8.0
631631
- More info: https://documentation.wazuh.com/current/release-notes/release-4-8-0.html
632-
* Thu Dec 07 2023 support <[email protected]> - 4.7.1
632+
* Tue Dec 05 2023 support <[email protected]> - 4.7.1
633633
- More info: https://documentation.wazuh.com/current/release-notes/release-4-7-1.html
634634
* Tue Nov 21 2023 support <[email protected]> - 4.7.0
635635
- More info: https://documentation.wazuh.com/current/release-notes/release-4-7-0.html
636-
* Tue Oct 24 2023 support <[email protected]> - 4.6.0
636+
* Tue Oct 31 2023 support <[email protected]> - 4.6.0
637637
- More info: https://documentation.wazuh.com/current/release-notes/release-4-6-0.html
638638
* Tue Oct 24 2023 support <[email protected]> - 4.5.4
639639
- More info: https://documentation.wazuh.com/current/release-notes/release-4-5-4.html

rpms/SPECS/wazuh-manager.spec

+8-3
Original file line numberDiff line numberDiff line change
@@ -115,7 +115,7 @@ mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/packages_files/manager_installation_
115115
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/{applications,generic}
116116
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/amzn/{1,2,2023}
117117
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/centos/{8,7,6,5}
118-
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/darwin/{15,16,17,18,19,20,21,22}
118+
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/darwin/{15,16,17,18,19,20,21,22,23}
119119
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/debian/{7,8,9,10,11}
120120
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/ubuntu/{12,14,16,18,20,22}/04
121121
mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/rhel/{9,8,7,6,5}
@@ -334,6 +334,9 @@ fi
334334
rm -f %{_localstatedir}/etc/shared/ar.conf >/dev/null 2>&1
335335
rm -f %{_localstatedir}/etc/shared/merged.mg >/dev/null 2>&1
336336

337+
# Set merged.mg permissions to new ones
338+
find %{_localstatedir}/etc/shared/ -type f -name 'merged.mg' -exec chmod 644 {} \;
339+
337340
#AlmaLinux
338341
if [ -r "/etc/almalinux-release" ]; then
339342
DIST_NAME=almalinux
@@ -787,6 +790,8 @@ rm -fr %{buildroot}
787790
%attr(640, root, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/darwin/21/*
788791
%dir %attr(750, wazuh, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/darwin/22
789792
%attr(640, root, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/darwin/22/*
793+
%dir %attr(750, wazuh, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/darwin/23
794+
%attr(640, root, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/darwin/23/*
790795
%dir %attr(750, wazuh, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/debian
791796
%attr(640, root, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/debian/*
792797
%dir %attr(750, wazuh, wazuh) %config(missingok) %{_localstatedir}/tmp/sca-%{version}-%{release}-tmp/rhel
@@ -852,11 +857,11 @@ rm -fr %{buildroot}
852857
- More info: https://documentation.wazuh.com/current/release-notes/release-4-8-1.html
853858
* Fri Dec 15 2023 support <[email protected]> - 4.8.0
854859
- More info: https://documentation.wazuh.com/current/release-notes/release-4-8-0.html
855-
* Thu Dec 07 2023 support <[email protected]> - 4.7.1
860+
* Tue Dec 05 2023 support <[email protected]> - 4.7.1
856861
- More info: https://documentation.wazuh.com/current/release-notes/release-4-7-1.html
857862
* Tue Nov 21 2023 support <[email protected]> - 4.7.0
858863
- More info: https://documentation.wazuh.com/current/release-notes/release-4-7-0.html
859-
* Tue Oct 24 2023 support <[email protected]> - 4.6.0
864+
* Tue Oct 31 2023 support <[email protected]> - 4.6.0
860865
- More info: https://documentation.wazuh.com/current/release-notes/release-4-6-0.html
861866
* Tue Oct 24 2023 support <[email protected]> - 4.5.4
862867
- More info: https://documentation.wazuh.com/current/release-notes/release-4-5-4.html

stack/dashboard/base/builder.sh

+1-1
Original file line numberDiff line numberDiff line change
@@ -119,7 +119,7 @@ sed -i "90s|defaultValue: true|defaultValue: false|g" ./src/core/server/opensear
119119
## Remove OpenSearch from the upper bar with empty svg
120120
cp ./etc/custom_welcome/Assets/default_branding/logo_full_alpha.svg ./src/core/server/core_app/assets/logos/opensearch_dashboards.svg
121121
cp ./etc/custom_welcome/Assets/default_branding/logo_full_alpha.svg ./src/core/server/core_app/assets/logos/opensearch_dashboards_on_light.svg
122-
cp ./etc/custom_welcome/Assets/default_branding/logo_full_alpha.svg ./src/core/server/core_app/assets/logos/opensearch_dashboards_on_darke.svg
122+
cp ./etc/custom_welcome/Assets/default_branding/logo_full_alpha.svg ./src/core/server/core_app/assets/logos/opensearch_dashboards_on_dark.svg
123123

124124
# Remove the `home` button from the sidebar menu
125125
sed -i 's|\["EuiHorizontalRule"\],{margin:"none"})),external_osdSharedDeps_React_default.a.createElement(external_osdSharedDeps_ElasticEui_\["EuiFlexItem"\],{grow:false,style:{flexShrink:0}},external_osdSharedDeps_React_default.a.createElement(external_osdSharedDeps_ElasticEui_\["EuiCollapsibleNavGroup"\]|["EuiHorizontalRule"],{margin:"none"})),false\&\&external_osdSharedDeps_React_default.a.createElem(external_osdSharedDeps_ElasticEui_["EuiFlexItem"],{grow:false,style:{flexShrink:0}},external_osdSharedDeps_React_default.a.createElement(external_osdSharedDeps_ElasticEui_["EuiCollapsibleNavGroup"]|' ./src/core/target/public/core.entry.js

stack/dashboard/base/generate_base.sh

+26-10
Original file line numberDiff line numberDiff line change
@@ -69,16 +69,32 @@ build() {
6969
# -----------------------------------------------------------------------------
7070

7171
help() {
72-
echo
73-
echo "Usage: $0 [OPTIONS]"
74-
echo
75-
echo " --app-url <url> [Optional] Set the repository from where the Wazuh plugin should be downloaded. By default, will be used pre-release."
76-
echo " -s, --store <path> [Optional] Set the destination path of package. By default, an output folder will be created."
77-
echo " --reference <ref> [Optional] wazuh-packages branch or tag"
78-
echo " --future [Optional] Build test future package 99.99.0 Used for development purposes."
79-
echo " -r, --revision <rev> [Optional] Package revision. By default ${revision}"
80-
echo " -h, --help Show this help."
81-
echo
72+
echo -e ""
73+
echo -e "NAME"
74+
echo -e " $(basename "$0") - Build Wazuh dashboard base file."
75+
echo -e ""
76+
echo -e "SYNOPSIS"
77+
echo -e " $(basename "$0") -a | -s | -b | -f | -r | -h"
78+
echo -e ""
79+
echo -e "DESCRIPTION"
80+
echo -e " --app-url <url>"
81+
echo -e " [Optional] Set the repository from where the Wazuh plugin should be downloaded."
82+
echo -e ""
83+
echo -e " -s, --store <path>"
84+
echo -e " [Optional] Set the destination path of package. By default, an output folder will be created."
85+
echo -e ""
86+
echo -e " --reference <ref>"
87+
echo -e " [Optional] wazuh-packages branch or tag."
88+
echo -e ""
89+
echo -e " --future"
90+
echo -e " [Optional] Build test future package. Used for development purposes."
91+
echo -e ""
92+
echo -e " -r, --revision <rev>"
93+
echo -e " [Optional] Package revision."
94+
echo -e ""
95+
echo -e " -h, --help"
96+
echo -e " Show this help."
97+
echo -e ""
8298
exit $1
8399
}
84100

0 commit comments

Comments
 (0)