File tree 3 files changed +6
-11
lines changed
3 files changed +6
-11
lines changed Original file line number Diff line number Diff line change 1
- # Copyright 1999-2021 Gentoo Authors
1
+ # Copyright 1999-2023 Gentoo Authors
2
2
# Distributed under the terms of the GNU General Public License v2
3
3
4
4
EAPI=7
@@ -14,13 +14,12 @@ SRC_URI="https://github.com/bitcoin-core/${MyPN}/archive/${COMMITHASH}.tar.gz ->
14
14
LICENSE=" MIT"
15
15
SLOT=" 0"
16
16
KEYWORDS=" amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
17
- IUSE=" +asm ecdh +experimental +extrakeys gmp lowmem precompute-ecmult +schnorr +recovery test test-openssl valgrind"
17
+ IUSE=" +asm ecdh +experimental +extrakeys gmp lowmem +recovery +schnorr test test-openssl valgrind"
18
18
RESTRICT=" !test? ( test )"
19
19
20
20
REQUIRED_USE="
21
21
asm? ( || ( amd64 arm ) arm? ( experimental ) )
22
22
extrakeys? ( experimental )
23
- ?? ( lowmem precompute-ecmult )
24
23
schnorr? ( experimental extrakeys )
25
24
test-openssl? ( test )
26
25
"
@@ -63,8 +62,7 @@ src_configure() {
63
62
--with-bignum=$( usex gmp gmp no) \
64
63
$( use_enable recovery module-recovery) \
65
64
$( use_enable schnorr module-schnorrsig) \
66
- $( usex lowmem ' --with-ecmult-window=2 --with-ecmult-gen-precision=2' ' ' ) \
67
- $( usex precompute-ecmult ' --with-ecmult-window=24 --with-ecmult-gen-precision=8' ' ' ) \
65
+ $( usex lowmem ' --with-ecmult-window=4 --with-ecmult-gen-precision=2' ' ' ) \
68
66
$( use_with valgrind) \
69
67
--disable-static
70
68
}
Original file line number Diff line number Diff line change @@ -13,11 +13,10 @@ SRC_URI="https://github.com/bitcoin-core/secp256k1/archive/v${PV}.tar.gz -> ${P}
13
13
LICENSE=" MIT"
14
14
SLOT=" 0/1" # subslot is "$((_LIB_VERSION_CURRENT-_LIB_VERSION_AGE))" from configure.ac
15
15
KEYWORDS=" ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
16
- IUSE=" +asm +ecdh experimental +extrakeys lowmem precompute-ecmult +schnorr +recovery test valgrind"
16
+ IUSE=" +asm +ecdh experimental +extrakeys lowmem +recovery +schnorr test valgrind"
17
17
RESTRICT=" !test? ( test )"
18
18
19
19
REQUIRED_USE="
20
- ?? ( lowmem precompute-ecmult )
21
20
asm? ( || ( amd64 arm ) arm? ( experimental ) )
22
21
schnorr? ( extrakeys )
23
22
"
@@ -46,8 +45,7 @@ src_configure() {
46
45
$( use_enable {,module-}extrakeys)
47
46
$( use_enable {,module-}recovery)
48
47
$( use_enable schnorr module-schnorrsig)
49
- $( usev lowmem ' --with-ecmult-window=2 --with-ecmult-gen-precision=2' )
50
- $( usev precompute-ecmult ' --with-ecmult-window=24 --with-ecmult-gen-precision=8' )
48
+ $( usev lowmem ' --with-ecmult-window=4 --with-ecmult-gen-precision=2' )
51
49
$( use_with valgrind)
52
50
)
53
51
if use asm; then
Original file line number Diff line number Diff line change 15
15
<flag name =" endomorphism" >Enable endomorphism</flag >
16
16
<flag name =" experimental" >Allow experimental USE flags</flag >
17
17
<flag name =" extrakeys" >Enable extrakeys module</flag >
18
- <flag name =" lowmem" >Reduce runtime memory usage at the expense of performance (ecmult window size 2, gen precision 2)</flag >
19
- <flag name =" precompute-ecmult" >Use over 512 MB memory at runtime for better performance (ecmult window size 24, gen precision 8)</flag >
18
+ <flag name =" lowmem" >Reduce runtime memory usage at the expense of performance (ecmult window size 4, gen precision 2)</flag >
20
19
<flag name =" recovery" >Enable ECDSA pubkey recovery module</flag >
21
20
<flag name =" schnorr" >Enable Schnorr signature module</flag >
22
21
<flag name =" test-openssl" >Enable OpenSSL comparison tests</flag >
You can’t perform that action at this time.
0 commit comments