Skip to content

v8.1.0

Latest
Compare
Choose a tag to compare
@HadrienG2 HadrienG2 released this 02 Feb 09:46
· 2 commits to main since this release
27e1e70

Added

  • Add Input::input_buffer_publisher() method to provide an RAII-based alternative to the low-level input_buffer()/publish() interface. Thanks @crop2000 !

Changed

  • Rename Input::input_buffer() to Input::input_buffer_mut(), keeping a deprecated alias for now, and do the same for Output::output_buffer(). This is the start of a gradual deprecation process whose end goal is to eventually follow the standard Rust accessor naming convention (input_buffer(&self) -> &T, input_buffer_mut(&mut self) -> &mut T, same thing on the output side).