Skip to content

Commit b24c321

Browse files
committed
buildroot: get rid of s390 support
As discussed on the list. It isn't supported by uclibc, so I strongly doubt anyone has been using it.
1 parent 5b220b9 commit b24c321

File tree

6 files changed

+1
-44
lines changed

6 files changed

+1
-44
lines changed

.defconfig

-1
Original file line numberDiff line numberDiff line change
@@ -15,7 +15,6 @@ BR2_i386=y
1515
# BR2_mipsel is not set
1616
# BR2_nios2 is not set
1717
# BR2_powerpc is not set
18-
# BR2_s390 is not set
1918
# BR2_sh is not set
2019
# BR2_sh64 is not set
2120
# BR2_sparc is not set

package/Makefile.in

-3
Original file line numberDiff line numberDiff line change
@@ -298,9 +298,6 @@ endif
298298
ifeq ($(BR2_m68k),y)
299299
BR2_AC_CV_TRAP_CHECK=ac_cv_lbl_unaligned_fail=no
300300
endif
301-
ifeq ($(BR2_s390),y)
302-
BR2_AC_CV_TRAP_CHECK=ac_cv_lbl_unaligned_fail=no
303-
endif
304301
ifeq ($(BR2_powerpc)$(BR2_ENDIAN),yBIG)
305302
BR2_AC_CV_TRAP_CHECK=ac_cv_lbl_unaligned_fail=no
306303
endif

package/liboil/liboil.mk

-3
Original file line numberDiff line numberDiff line change
@@ -22,9 +22,6 @@ endif
2222
ifeq ($(BR2_nios2),y)
2323
LIBOIL_CONF_ENV = as_cv_unaligned_access=no
2424
endif
25-
ifeq ($(BR2_s390),y)
26-
LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
27-
endif
2825
ifeq ($(BR2_x86_64),y)
2926
LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
3027
endif

package/multimedia/gstreamer/gstreamer.mk

-3
Original file line numberDiff line numberDiff line change
@@ -17,9 +17,6 @@ endif
1717
ifeq ($(BR2_nios2),y)
1818
GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
1919
endif
20-
ifeq ($(BR2_s390),y)
21-
GSTREAMER_CONF_ENV = as_cv_unaligned_access=yes
22-
endif
2320

2421
GSTREAMER_CONF_OPT = \
2522
$(DISABLE_NLS) \

target/Config.in.arch

-33
Original file line numberDiff line numberDiff line change
@@ -30,8 +30,6 @@ config BR2_nios2
3030
bool "nios2"
3131
config BR2_powerpc
3232
bool "powerpc"
33-
config BR2_s390
34-
bool "s390"
3533
config BR2_sh
3634
bool "superh"
3735
config BR2_sh64
@@ -308,25 +306,6 @@ config BR2_alpha_21264a
308306
bool "21264a"
309307
endchoice
310308

311-
choice
312-
prompt "Target Architecture Variant"
313-
depends on BR2_s390
314-
default BR2_s390_g5
315-
help
316-
Specific CPU variant to use
317-
318-
config BR2_s390_g5
319-
bool "g5"
320-
config BR2_s390_g6
321-
bool "g6"
322-
config BR2_s390_z900
323-
bool "z900"
324-
config BR2_s390_z990
325-
bool "z990"
326-
config BR2_s390_z9_109
327-
bool "z9_109"
328-
endchoice
329-
330309
choice
331310
prompt "Target Architecture Variant"
332311
depends on BR2_sparc
@@ -497,8 +476,6 @@ config BR2_ARCH
497476
default "mipsel" if BR2_mipsel
498477
default "nios2" if BR2_nios2
499478
default "powerpc" if BR2_powerpc
500-
default "s390" if BR2_s390
501-
default "s390" if BR2_s390x
502479
default "sh2a_nofpueb" if BR2_sh2a_nofpueb
503480
default "sh2eb" if BR2_sh2eb
504481
default "sh3" if BR2_sh3
@@ -646,11 +623,6 @@ config BR2_GCC_TARGET_TUNE
646623
default ultrasparc if BR2_sparc_ultrasparc || BR2_sparc64_ultrasparc
647624
default ultrasparc3 if BR2_sparc_ultrasparc3 || BR2_sparc64_ultrasparc3
648625
default niagara if BR2_sparc_niagara || BR2_sparc64_niagara
649-
default g5 if BR2_s390_g5
650-
default g6 if BR2_s390_g6
651-
default z900 if BR2_s390_z900
652-
default z990 if BR2_s390_z990
653-
default z9-109 if BR2_s390_z9_109
654626

655627
config BR2_GCC_TARGET_ARCH
656628
string
@@ -690,11 +662,6 @@ config BR2_GCC_TARGET_ARCH
690662
default 68030 if BR2_m68k_68030
691663
default 68040 if BR2_m68k_68040
692664
default 68060 if BR2_m68k_68060
693-
default g5 if BR2_s390_g5
694-
default g6 if BR2_s390_g6
695-
default z900 if BR2_s390_z900
696-
default z990 if BR2_s390_z990
697-
default z9-109 if BR2_s390_z9_109
698665

699666
config BR2_GCC_TARGET_ABI
700667
string

toolchain/kernel-headers/kernel-headers.mk

+1-1
Original file line numberDiff line numberDiff line change
@@ -17,7 +17,7 @@ LINUX_HEADERS_UNPACK_DIR:=$(TOOL_BUILD_DIR)/linux-libc-headers-null
1717
KERNEL_ARCH:=$(shell $(SHELL) -c "echo \"$(ARCH)\" | sed -e \"s/-.*//\" \
1818
-e s/i.86/i386/ -e s/sun4u/sparc64/ \
1919
-e s/arm.*/arm/ -e s/sa110/arm/ \
20-
-e s/s390x/s390/ -e s/parisc64/parisc/ \
20+
-e s/parisc64/parisc/ \
2121
-e s/powerpc64/powerpc/ \
2222
-e s/ppc.*/powerpc/ -e s/mips.*/mips/ \
2323
-e s/sh2.*/sh/ -e s/sh3.*/sh/ -e s/sh4.*/sh/ \

0 commit comments

Comments
 (0)